
How to avoid 

broken 

formulas 
Applies To: Excel 2016 Excel 2013 Excel 2010 Excel 2007 

Excel 2016 for Mac Excel Online Excel for iPad Excel for 

Android tablets Excel Starter More... Less  

If Excel can’t resolve a formula you’re trying to create, you may 

get an error message like this one:  

 

Unfortunately, this means that Excel can’t understand what 

you’re trying to do, so you might just want to get out of here 

and start over.  
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Start by clicking OK or press ESC to close the error message.  

You'll return to the cell with the broken formula, which will be 

in edit mode, and Excel will highlight the spot where it’s having 

a problem. If you still don’t know what to do from there and 

want to start over, you can press ESC again, or click the Cancel 

button in the formula bar, which will exit you out of edit mode.  

 

If you’re not sure what to do at this point or what kind of help 

you need, you can search for similar questions in the Excel 

Community Forum, or post one of your own.  

 

If you want to move forward, then the following checklist 

provides troubleshooting steps to help you figure out what 

may have gone wrong in your formulas. 

 

Are you seeing a hash (#) error? 

 
Excel throws a variety of hash (#) errors such as #VALUE!, 

#REF!, #NUM, #N/A, #DIV/0!, #NAME?, and #NULL!, to 

indicate something in your formula is not working right. For 

example, the #VALUE! error is caused by incorrect 

http://go.microsoft.com/fwlink/?LinkId=799646
http://go.microsoft.com/fwlink/?LinkId=799646
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formatting, or unsupported data types in arguments. Or, 

you will see the #REF! error if a formula refers to cells that 

have been deleted or replaced with other data. 

Troubleshooting guidance will differ for each error.  

Note: #### is not a formula-related error. It just means that 

the column isn't wide enough to display the cell contents. 

Simply drag the column to widen it, or go to Home > 

Format > AutoFit Column Width.  

 

Refer to any of the following topics corresponding to the 

hash error that you see: 

• Correct a #NUM! error  

• Correct a #VALUE! error  

• Correct a #N/A error  

• Correct a #DIV/0! error  

• Correct a #REF! error  

• Correct a #NAME? error  

• Correct a #NULL! error  

 

https://support.office.com/en-gb/article/Correct-a-NUM-error-f5193bfc-4400-43f4-88c4-8e1dcca0428b
https://support.office.com/en-gb/article/Correct-a-VALUE-error-15e1b616-fbf2-4147-9c0b-0a11a20e409e
https://support.office.com/en-gb/article/Correct-a-NA-error-a9708411-f82e-4e1b-8a7e-28c28311b993
https://support.office.com/en-gb/article/Correct-a-DIV0-error-3a5a18a9-8d80-4ebb-a908-39e759a009a5
https://support.office.com/en-gb/article/Correct-a-REF-error-822c8e46-e610-4d02-bf29-ec4b8c5ff4be
https://support.office.com/en-gb/article/Correct-a-NAME-error-b6d54e31-a743-4d7d-9b61-40002a7b4286
https://support.office.com/en-gb/article/Correct-a-NULL-error-c08ed643-ef4d-4735-bc74-f29296632f0d
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There are broken links in the 

formula 

 
Each time you open a spreadsheet that contains formulas 

referring to values in other spreadsheets, you will be 

prompted to update the references or leave them as-is.  

 

Excel displays the above dialog box to make sure that the 

formulas in the current spreadsheet always point to the 

most updated value, in case the reference value has 

changed. You can choose to update the references, or skip 

if you don't want to update. Even if you choose to not 

update the references, you can always manually update the 

links in the spreadsheet whenever you want.  

You can always disable the dialog box from appearing at 

start up. To do that, go to File > Options > Advanced > 

General, and uncheck Ask to update automatic links. In 

Excel 2007 you would click the Office Button > Excel 

Options.  
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Important: If this is the first time you are working with 

broken links in formulas, need a refresher on resolving 

broken links, or you don't know whether to update the 

references, see Control when external references (links) are 

updated. 

 

The formula displays the syntax, 

and not the value 

 
If the formula doesn't display the value, follow these steps: 

• Make sure that the Excel is set to show formulas in your 

spreadsheet. To do this, click the Formulas tab, and in the 

Formula Auditing group, click Show Formulas.  

Tip: You can also use the keyboard shortcut Ctrl + ` (the key 

above the Tab key). When you do this, your columns will 

automatically widen to display your formulas, but don’t worry, 

when you toggle back to normal view your columns will resize. 

https://support.office.com/en-gb/article/Control-when-external-references-links-are-updated-21e995b5-bab1-4328-8ab3-dd357fe0e653
https://support.office.com/en-gb/article/Control-when-external-references-links-are-updated-21e995b5-bab1-4328-8ab3-dd357fe0e653
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• If the above step still doesn't resolve the issue, it's possible the 

cell is formatted as text. You can right-click on the cell and select 

Format Cells > General (or Ctrl + 1), then press F2 > Enter to 

change the format. 

• If you have a large range of cells in a column that are formatted 

as text, then you can select the range, apply the number format 

of you choice and go to Data > Text to Column > Finish. This 

will apply the format to all of the selected cells. 

 

 

The formula is not calculating 

 
When a formula does not calculate, you have to check if 

automatic calculation is enabled in Excel. Formulas will not 
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calculate if manual calculation is enabled. Follow these steps 

to check for Automatic calculation: 

1. Click the File tab, click Options, and then click the Formulas 

category. 

2. In the Calculation options section, under Workbook 

Calculation, make sure the Automatic option is selected. 

 

For more information on calculations, see Change formula 

recalculation, iteration, or precision. 

 

There are one or more circular 

references in the formula 

 
A circular reference occurs when a formula refers to the cell 

that it is located in. The fix is to either move the formula to 

another cell or change the formula syntax, one that avoids 

circular references. However, in some scenarios you may 

https://support.office.com/en-US/article/Change-formula-recalculation-iteration-or-precision-F38C7793-0367-41CE-B892-DFE54946BD76
https://support.office.com/en-US/article/Change-formula-recalculation-iteration-or-precision-F38C7793-0367-41CE-B892-DFE54946BD76
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need circular references because they cause your functions 

to iterate—repeat until a specific numeric condition is met. 

In such a case, you will need to enable Iterative Calculation. 

For more information on circular references, see Find and fix 

a circular reference 

 

Does your function start with an 

equal sign (=)? 

 
If your entry doesn’t start with an equal sign, it isn’t a 

formula, and won’t be calculated—a common mistake.  

When you type something like SUM(A1:A10), Excel shows 

the text string SUM(A1:A10) instead of a formula result. 

Now if you type 11/2, Excel shows a date, such as 2-Nov or 

11/02/2009, instead of dividing 11 by 2.  

To avoid these unexpected results, always start the function 

with an equal sign. For example, type: =SUM(A1:A10) and 

=11/2 

 

https://support.office.com/en-us/article/find-and-fix-a-circular-reference-c17488e3-3cbe-4fa8-a6bc-1a6ffa64db78
https://support.office.com/en-US/article/Find-and-fix-a-circular-reference-C17488E3-3CBE-4FA8-A6BC-1A6FFA64DB78
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Have you matched the opening 

and closing parentheses? 

 
When you use a function in a formula, each opening 

parenthesis needs a closing parenthesis for the function to 

work correctly, so make sure that all parentheses are part of 

a matching pair. For example, the formula =IF(B5<0),"Not 

valid",B5*1.05) won’t work because there are two closing 

parentheses but only one opening parenthesis. The correct 

formula would look like this: =IF(B5<0,"Not 

valid",B5*1.05). 

 

Are all required arguments 

present in the syntax? 

 
Excel functions have arguments—values you need to 

provide for the function to work. Only a few functions (such 

as PI or TODAY) take no arguments. Check the formula 

syntax that appears as you start typing in the function, to 

make sure the function has the required arguments. 
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For example, the UPPER function accepts only one string of 

text or cell reference as its argument: =UPPER("hello") or 

=UPPER(C2) 

Note: You will see the function’s arguments listed in a 

floating function reference toolbar beneath the formula as 

you are typing it. 

 
Function reference toolbar 

Also, some functions, such as SUM, require numerical 

arguments only, while other functions, such as REPLACE, 

require a text value for at least one of their arguments. If 

you use the wrong data type, functions might return 

unexpected results or show a #VALUE! error. 

If you need to quickly look up the syntax of a particular 

function, see the list of Excel functions (by category). 

 

Are there any unformatted 

numbers in formulas? 

 

https://support.office.com/en-gb/article/UPPER-c11f29b3-d1a3-4537-8df6-04d0049963d6
https://support.office.com/en-gb/article/SUM-043e1c7d-7726-4e80-8f32-07b23e057f89
https://support.office.com/en-gb/article/REPLACE-8d799074-2425-4a8a-84bc-82472868878a
https://support.office.com/en-gb/article/VALUE-15e1b616-fbf2-4147-9c0b-0a11a20e409e
https://support.office.com/en-us/article/Excel-functions-by-category-5F91F4E9-7B42-46D2-9BD1-63F26A86C0EB
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Don't enter numbers formatted with dollar signs ($) or 

decimal separators (,) in formulas, because dollar signs 

indicate Absolute References and commas are argument 

separators. Instead of entering $1,000, enter 1000 in the 

formula. 

If you use formatted numbers in arguments, you’ll get 

unexpected calculation results, but you may also see the 

#NUM! error. For example, if you enter the formula =ABS(-

2,134) to find the absolute value of -2134, Excel shows the 

#NUM! error, because the ABS function accepts only one 

argument. 

Note: You can format the formula result with decimal 

separators and currency symbols after you enter the 

formula using unformatted numbers (constants). It’s 

generally not a good idea to put constants in formulas, 

because they can be hard to find if you need to update 

later, and they are more prone to being typed incorrectly. 

It’s much better to put your constants in cells, where they 

are out in the open and easily referenced. 

 

Do the referred cells belong to 

the correct data type? 

 

https://support.office.com/en-us/article/Switch-between-relative-absolute-and-mixed-references-DFEC08CD-AE65-4F56-839E-5F0D8D0BACA9?ui=en-US&rs=en-US&ad=US
https://support.office.com/en-gb/article/NUM-f5193bfc-4400-43f4-88c4-8e1dcca0428b
https://support.office.com/en-gb/article/ABS-function-3420200f-5628-4e8c-99da-c99d7c87713c
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Your formula might not return expected results if the cell’s 

data type can’t be used in calculations. For example, if you 

enter a simple formula =2+3 in a cell that’s formatted as 

text, Excel can’t calculate the data you entered. All you'll see 

in the cell is =2+3. To fix this, change the cell’s data type 

from Text to General like this: 

1. Select the cell. 

2. Click Home > arrow next to Number Format (or press Ctrl + 1), 

and click General. 

3. Press F2 to put the cell in the edit mode, and then press Enter to 

accept the formula. 

A date you enter in a cell that’s using the Number data 

type might be shown as a numeric date value instead of a 

date. To show a number as a date, pick a Date format in the 

Number Format gallery. 

 

Are you trying to multiply 

without using the * symbol?  

 
It's fairly common to use x as the multiplication operator in 

a formula, but Excel can only accept the asterisk (*) for 

multiplication. If you use constants in your formula, Excel 

shows an error message and can fix the formula for you by 

replacing the x with the asterisk (*). 
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Error message using x with constants to multiply instead of * 

However, if you use cell references, Excel will return a 

#NAME? error. 

 
#NAME? error using x with cell references instead of * 

 

Are quotation marks missing 

around text in formulas? 

 
If you create a formula that includes text, enclose the text in 

quotation marks.  

For example, the formula ="Today is " & 

TEXT(TODAY(),"dddd, mmmm dd") combines the text 

"Today is " with the results of the TEXT and TODAY 
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functions, and returns say something like Today is 

Monday, May 30. 

In the formula, "Today is " has a space before the ending 

quotation mark to provide the blank space you want 

between the words "Today is" and "Monday, May 30." 

Without quotation marks around the text, the formula 

might show the #NAME? error. 

 

Are there more than 64 

functions in a formula? 

 
You can combine (or nest) up to 64 levels of functions 

within a formula.  

For example, the formula =IF(SQRT(PI())<2,"Less than 

two!","More than two!") has 3 levels of functions: The PI 

function is nested inside the SQRT function, which in turn is 

nested inside the IF function. 

 

https://support.office.com/en-gb/article/NAME-error-b6d54e31-a743-4d7d-9b61-40002a7b4286
javascript:
javascript:
javascript:
javascript:
https://support.office.com/en-gb/article/PI-function-264199d0-a3ba-46b8-975a-c4a04608989b
https://support.office.com/en-gb/article/PI-function-264199d0-a3ba-46b8-975a-c4a04608989b
https://support.office.com/en-gb/article/SQRT-function-654975c2-05c4-4831-9a24-2c65e4040fdf
https://support.office.com/en-gb/article/IF-function-0f1a0f81-f6e1-46e4-9cd4-9e65445fc3ab
javascript:


Are sheet names enclosed in 

single quotation marks? 

 
When you type a reference to values or cells in another 

worksheet, and the name of that sheet has a non-

alphabetical character (such as a space), enclose the name 

in single quotation marks ('). 

For example, to return the value from cell D3 in a worksheet 

named Quarterly Data in your workbook, type: ='Quarterly 

Data'!D3. Without the quotation marks around the sheet 

name, the formula shows the #NAME? error. 

You can also click the values or cells in another sheet to 

refer to them in your formula. Excel then automatically adds 

the quotation marks around the sheet names. 

 

If the formula references to an 

external workbook, is the path 

to the workbook referenced 

correctly? 
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When you type a reference to values or cells in another 

workbook, include the workbook name enclosed in square 

brackets ([]) followed by the name of the worksheet that has 

the values or cells. 

For example, to refer to cells A1 through A8 on the Sales 

sheet in the Q2 Operations workbook that’s open in Excel, 

type: =[Q2 Operations.xlsx]Sales!A1:A8. Without the 

square brackets, the formula shows the #REF! error. 

If the workbook isn’t open in Excel, type the full path to the 

file. 

For example, =ROWS('C:\My Documents\[Q2 

Operations.xlsx]Sales'!A1:A8). 

Note:  If the full path has space characters, enclose the path 

in single quotation marks (at the beginning of the path and 

after the name of the worksheet, before the exclamation 

point). 

Tip: The easiest way to get the path to the other workbook 

is to open the other workbook, then from your original 

workbook, type =, then use Alt+Tab to shift to the other 

workbook and select any cell on the sheet you want. Then 

close the source workbook. Your formula will automatically 

update to display the full file path and sheet name along 

with the required syntax. You can even copy and paste the 

path and use wherever you need it. 

https://support.office.com/en-gb/article/REF-error-822c8e46-e610-4d02-bf29-ec4b8c5ff4be


 

Are you dividing numeric values 

by zero? 

 
Dividing a cell by another cell that has zero (0) or no value 

results in a #DIV/0! error.  

To avoid this error, you can address it directly and test for 

the existence of the denominator. 

=IF(B1,A1/B1,0) 

Which says IF(B1 exists, then divide A1 by B1, otherwise 

return a 0). 

 

Is the formula referencing to 

deleted data? 

 
Always check to see if you have any formulas that refer to 

data in cells, ranges, defined names, worksheets, or 

workbooks, before you delete anything. You can then 
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replace these formulas with their results before you remove 

the referenced data. 

If you can’t replace the formulas with their results, review 

this information about the errors and possible solutions: 

• If a formula refers to cells that have been deleted or replaced 

with other data and returns a #REF! error, select the cell with the 

#REF! error. In the formula bar, select #REF! and delete it. Then, 

reenter the range for the formula.  

• If a defined name is missing, and a formula that refers to that 

name returns a #NAME? error, define a new name that refers to 

the range you want, or change the formula to refer directly to 

the range of cells (for example, A2:D8). 

• If a worksheet is missing, and a formula that refers to it returns a 

#REF! error, there’s no way to fix this, unfortunately—a 

worksheet that’s been deleted can't be recovered. 

• If a workbook is missing, a formula that refers to it remains intact 

until you update the formula. 

For example, if your formula is =[Book1.xlsx]Sheet1'!A1 and 

you no longer have Book1.xlsx, the values referenced in that 

workbook stay available. However, if you edit and save a formula 

that refers to that workbook, Excel shows the Update Values 

dialog box and prompts you to enter a file name. Click Cancel, 

and then make sure that this data isn’t lost by replacing the 

formulas that refer to the missing workbook with the formula 

results. 

 

https://support.office.com/en-gb/article/replace-these-formulas-with-their-results-0535c161-c013-463e-b42f-53b7655b005b
https://support.office.com/en-gb/article/REF-error-822c8e46-e610-4d02-bf29-ec4b8c5ff4be
https://support.office.com/en-gb/article/NAME-error-b6d54e31-a743-4d7d-9b61-40002a7b4286
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Have you copied and pasted 

cells associated to a formula in 

the spreadsheet? 

 
Sometimes, when you copy the contents of a cell, you want 

to paste just the value and not the underlying formula that 

is displayed in the formula bar. 

For example, you might want to copy the resulting value of 

a formula to a cell on another worksheet. Or you might 

want to delete the values that you used in a formula after 

you copied the resulting value to another cell on the 

worksheet. Both of these actions cause an invalid cell 

reference error (#REF!) to appear in the destination cell, 

because the cells that contain the values that you used in 

the formula can no longer be referenced. 

You can avoid this error by pasting the resulting values of 

formulas without the formula in destination cells. 

1. On a worksheet, select the cells that contain the resulting values 

of a formula that you want to copy. 

2. On the Home tab, in the Clipboard group, click Copy . 

 

javascript:
javascript:
javascript:
javascript:


Keyboard shortcut: Press CTRL+C. 

3. Select the upper-left cell of the paste area. 

Tip: To move or copy a selection to a different worksheet or 

workbook, click another worksheet tab or switch to another 

workbook, and then select the upper-left cell of the paste area 

4. On the Home tab, in the Clipboard group, click Paste , and 

then click Paste Values, , or press Alt > E > S > V > Enter for 

Windows, or Option > Command > V > V > Enter on a Mac. 

 

If you have a nested formula, 

evaluate the formula one step 

at a time 

 
To understand how a complex or nested formula calculates 

the final result, you can evaluate that formula. 

1. Select the formula you want to evaluate. 

2. Click Formulas > Evaluate Formula. 
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3. Click Evaluate to examine the value of the underlined reference. 

The result of the evaluation is shown in italics. 

 

4. If the underlined part of the formula is a reference to another 

formula, click Step In to show the other formula in the 

Evaluation box. Click Step Out to go back to the previous cell 

and formula. 

The Step In button isn’t available the second time the reference 

appears in the formula, or if the formula refers to a cell in 

another workbook. 

5. Continue until each part of the formula has been evaluated. 

The Evaluate Formula tool won't necessary tell you why your 

formula is broken, but it can help point out where. This can be a 

very handy tool in larger formulas where it might otherwise be 

difficult to find the problem. 

Notes:  

o Some parts of the IF and CHOOSE functions won’t be evaluated, and 

the #N/A error might appear in the Evaluation box. 

o Blank references are shown as zero values (0) in the Evaluation box. 

o Functions that are recalculated every time the worksheet changes. 

Those functions, including the RAND, AREAS, INDEX, OFFSET, CELL, 

INDIRECT, ROWS, COLUMNS, NOW, TODAY, and RANDBETWEEN 

https://support.office.com/en-gb/article/IF-69aed7c9-4e8a-4755-a9bc-aa8bbff73be2
https://support.office.com/en-gb/article/CHOOSE-fc5c184f-cb62-4ec7-a46e-38653b98f5bc
https://support.office.com/en-gb/article/RAND-4cbfa695-8869-4788-8d90-021ea9f5be73
https://support.office.com/en-gb/article/AREAS-8392ba32-7a41-43b3-96b0-3695d2ec6152
https://support.office.com/en-gb/article/INDEX-a5dcf0dd-996d-40a4-a822-b56b061328bd
https://support.office.com/en-gb/article/OFFSET-c8de19ae-dd79-4b9b-a14e-b4d906d11b66
https://support.office.com/en-gb/article/CELL-51bd39a5-f338-4dbe-a33f-955d67c2b2cf
https://support.office.com/en-gb/article/INDIRECT-474b3a3a-8a26-4f44-b491-92b6306fa261
https://support.office.com/en-gb/article/ROWS-b592593e-3fc2-47f2-bec1-bda493811597
https://support.office.com/en-gb/article/COLUMNS-4e8e7b4e-e603-43e8-b177-956088fa48ca
https://support.office.com/en-gb/article/NOW-3337fd29-145a-4347-b2e6-20c904739c46
https://support.office.com/en-gb/article/TODAY-5eb3078d-a82c-4736-8930-2f51a028fdd9
https://support.office.com/en-gb/article/RANDBETWEEN-4cc7f0d1-87dc-4eb7-987f-a469ab381685


functions, can cause the Evaluate Formula dialog box to show 

results that are different from the actual results in the cell on the 

worksheet. 

 


